I think there's a bug

November 15th, 2012 at 12:56:02 AM permalink
AcesAndEights
Member since: Oct 24, 2012
Threads: 5
Posts: 238
Consistently observed bug for me, that's not at WoV: when I'm reading the "Recent Threads" page, if I click on a thread which satisfies:
A) It has multiple pages
B) I have not read any posts
It takes me to the top of the 2nd page of the thread. Since I haven't read the thread at all, it should naturally take me to the first page/first post. As far as I can tell, this is what happens on WoV.

Note that it's hard to repro this exactly, since there aren't a ton of posts here yet, especially multi-page threads that I've missed entirely. I was gone for a long weekend and noticed this happen multiple times - on a post which had 3 pages, it definitely took me to the top of the 2nd page, and not the 3rd (or other last) page (AZD's gay marriage thread). Off-by-one error somewhere? Just a conjecture.
"You think I'm joking." -EvenBob
November 15th, 2012 at 3:08:30 AM permalink
JB
Administrator
Member since: Oct 23, 2012
Threads: 9
Posts: 81
Others have mentioned this, and I've encountered it a couple of times myself. I'm not yet sure what is causing it, since the code is mostly the same here as it is on WoV, but it's on my list of things to do.
November 15th, 2012 at 10:29:57 AM permalink
AcesAndEights
Member since: Oct 24, 2012
Threads: 5
Posts: 238
Quote: JB
Others have mentioned this, and I've encountered it a couple of times myself. I'm not yet sure what is causing it, since the code is mostly the same here as it is on WoV, but it's on my list of things to do.

I thought I remembered someone else mentioning it, but couldn't find the post to add my +1 instead of posting again. Anyway, good to know you're aware of it. Clearly this is greatly impacting my quality of life. I didn't sleep that well last night because of it.
"You think I'm joking." -EvenBob
November 21st, 2012 at 7:43:50 AM permalink
JB
Administrator
Member since: Oct 23, 2012
Threads: 9
Posts: 81
I think I found and fixed this bug.
November 21st, 2012 at 4:38:12 PM permalink
AcesAndEights
Member since: Oct 24, 2012
Threads: 5
Posts: 238
Quote: JB
I think I found and fixed this bug.

Cool. I'll have to have another long layoff to test your fix :).
"You think I'm joking." -EvenBob
December 4th, 2012 at 1:19:32 AM permalink
AcesAndEights
Member since: Oct 24, 2012
Threads: 5
Posts: 238
Quote: AcesAndEights
Cool. I'll have to have another long layoff to test your fix :).

Well I took another long weekend off from the forum, and I am sad to report that the issue is not fixed.

However, I have some additional information that will hopefully be helpful. When I opened the "Recent Threads" page today, I clicked on the link to "Mayan Calendar Countdown." After realizing I had fallen victim to the bug again and was looking at the 2nd page of a thread I had never opened before, I took careful note of the exact URL I followed to get there:

http://diversitytomorrow.com/thread/147/1/#post1829

You'll notice that if you follow that link, post 1829 does not appear on that page (which happens to the 2nd page of the thread, indicated by "1" in the URL [zero-indexing being the custom, of course]). Post 1829 does appear on the first page of the thread, so replacing the 1 with a 0 above, or just removing that part of the URL, gets you to the expected place.

So the anchor link is correct, just not the base URL. I checked on WoV, and thread pages over there seem to be 1-indexed. For example:
http://wizardofvegas.com/forum/las-vegas-casinos/riviera/12139-alfreds-spotted-dick/3/
That link goes to the 3rd page of the thread, appending a '0' or '1' to the URL both go to the first page. So one of the two forums has a special case hacked in somewhere, but without the requisite fix on the "Recent Threads" logic.
"You think I'm joking." -EvenBob
December 4th, 2012 at 2:17:23 AM permalink
JB
Administrator
Member since: Oct 23, 2012
Threads: 9
Posts: 81
Quote: AcesAndEights
I am sad to report that the issue is not fixed.

My apologies. It was only fixed on the home page, not the recent threads page. Now it has been fixed there.
December 4th, 2012 at 10:42:56 AM permalink
AcesAndEights
Member since: Oct 24, 2012
Threads: 5
Posts: 238
Quote: JB
My apologies. It was only fixed on the home page, not the recent threads page. Now it has been fixed there.

Cool thanks. Later tonight I my create a test user to verify your fix, if that's okay with you. You can delete the thread after it's done. I may be taking this way too seriously.
"You think I'm joking." -EvenBob
November 22nd, 2016 at 1:44:33 PM permalink
rxwine
Member since: Oct 24, 2012
Threads: 111
Posts: 4447
Either the Wizard Odds site has been down much of the day, or I'm on the other side of some individual broken hub.

One day I will understand this internet with tubes things and how it works. But not today.
No one has ever proven I am not God.
November 22nd, 2016 at 1:50:20 PM permalink
Nareed
Member since: Oct 24, 2012
Threads: 301
Posts: 10009
Quote: rxwine
Either the Wizard Odds site has been down much of the day, or I'm on the other side of some individual broken hub.

One day I will understand this internet with tubes things and how it works. But not today.


Yesterday for a long while I couldn't access Facebook, this site and a few others, and the rest were painfully slow or loaded only ads.

Since I read nothing about a DOS, I assume it was my ISP with the problem.
If Trump where half as smart as he thinks he is, he'd be twice as smart as he really is.